Просмотр объектов очереди сообщений в 1С:Документооборот

Публикация № 1704079 02.08.22

Пользовательские инструменты - Адаптация типовых решений

Документооборот очередь сообщений бесшовная интеграция просмотр XML

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

Ценность в том, что можно видеть, с каким именно документом выдает проблему интеграция и перейти к фиксации ошибки на конкретных данных (в типовом варианте объект с ошибкой не виден).

Навигационная ссылка на регистр: e1cib/list/РегистрСведений.ОчередьСообщенийВ1СДокументооборот

Типовой вид:

 

 

Дополненный вид (закладка Дополнительно):

 

 

Листинг кода вывода данных XML:

&НаКлиенте
Процедура росд__СписокПриАктивизацииСтрокиПосле(Элемент)
	
	ТекстДанных.Очистить();
	
	ТекущиеДанные = Элементы._Список.ТекущиеДанные;
	
	Если ТекущиеДанные <> Неопределено Тогда
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		росд_ПолучитьДанныеСообщения(ТекущиеДанные.Идентификатор, ТекущиеДанные.МоментВремени);
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Функция росд_ПолучитьДанныеСообщения(Идентификатор, МоментВремени)
	
	Данные = "";
	
	МЗ = РегистрыСведений.ОчередьСообщенийВ1СДокументооборот.СоздатьМенеджерЗаписи();
	МЗ.Идентификатор = Идентификатор;
	МЗ.МоментВремени = МоментВремени;
	МЗ.Прочитать();
	
	Если МЗ.Выбран() = Истина Тогда
		Данные = МЗ.Данные.Получить();
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		Данные.Записать(ИмяВФ);
		ТекстДанных.Прочитать(ИмяВФ);
		УдалитьФайлы(ИмяВФ);
	КонецЕсли;
	
	Возврат Данные;
	
КонецФункции

Проверялось на:

1С:ERP Управление предприятием 2 (2.4.14.181)

1С:ERP Управление предприятием 2 (2.5.8.207)

 

 
 Как подключить расширение к базе 1С
 
 Другие публикации автора

Ссылка на компетенции по 1С:ERP - команда со знаниями, умениями и успешными проектами.

Скачать файлы

Наименование Файл Версия Размер
Расширение: Просмотр объектов очереди сообщений в 1С:Документоборот (Версия 01.08.2022):

.cfe 12,83Kb
11
.cfe 12,83Kb 11 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. aximo 1906 02.08.22 13:52 Сейчас в теме
спасибо. понятно назначение
что-то делал подобное для фискальных операций в рознице - https://infostart.ru/public/1311937/
2. triviumfan 29 02.08.22 22:58 Сейчас в теме
Поидее он же чисто для служебного пользования, отладки, т.е. для программистов, ничего полезного для обычных пользователей он не скажет.
sapervodichka; +1 Ответить
3. sapervodichka 5681 02.08.22 23:09 Сейчас в теме
(2) так и есть (>_<) он для "необычных пользователей"
Maxim_Zuev; Torin; +2 Ответить
4. LomayaZakat 08.08.22 08:41 Сейчас в теме
Листинг под современные нужды:
&НаКлиенте
Процедура НЕО_СписокПриАктивизацииСтрокиПосле(Элемент)
	
	ТекстДанных.Очистить();
	ТекущиеДанные = Элементы.Список.ТекущиеДанные;
	
	Если ТекущиеДанные <> Неопределено Тогда
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		ПолучитьДанныеСообщения(ТекущиеДанные.Идентификатор, ТекущиеДанные.ДатаСоздания);
	КонецЕсли; 
	
КонецПроцедуры   

&НаСервере
Процедура ПолучитьДанныеСообщения(Идентификатор, ДатаСоздания)
	
	Данные = "";
	
	НаборЗаписей = РегистрыСведений.ОчередьСообщенийВ1СДокументооборот.СоздатьНаборЗаписей();
	НаборЗаписей.Отбор.Идентификатор.Установить(Идентификатор);
	НаборЗаписей.Прочитать();
	
	Для Каждого Строка из НаборЗаписей Цикл
		Данные = Строка.Данные.Получить();
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		Данные.Записать(ИмяВФ);
		ТекстДанных.Прочитать(ИмяВФ);
		УдалитьФайлы(ИмяВФ);
	КонецЦикла;
	
КонецПроцедуры
Показать
Оставьте свое сообщение

См. также

SALE! 25%

Из Excel в 1С "одним нажатием": УПД, ТОРГ-12, отчеты комиссионеров (ОЗОН, Вайлдберриз), заказы, счета, прайсы, номенклатура Промо

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля v8 v8::УФ Платформа 1C v8.2 1cv8.cf БУ УУ Платные (руб)

Универсальная обработка для загрузки документов из Excel в 1С. Не требует указания параметров (номера колонок, номер первой строки таблицы и т.д.) и предварительной настройки. Просто выбираете файл Excel, документ 1С и нажимаете кнопку "Загрузить". Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. Вместе с номенклатурой может найти контрагента, номер и дату документа, штрих-коды, серии ГТД, страну и т.д. Распознает документы ЛЮБОЙ ФОРМЫ (УПД, ТОРГ-12, заказ, отчет комиссионера и т.д.). Не требует MS Office. Содержит модуль работы с электронной почтой. Для поиска таблиц используются методы эвристического поиска. Загружает только то, что нужно, т.е. пропускает повторы шапки таблицы, заголовки, промежуточные итоги, подписи и т.д. Работает во всех основных конфигурациях 1С8. При покупке лицензии вы получите 1 месяц бесплатной тех.поддержки.

9000 7650 руб.

09.11.2016    175191    648    839    

Загрузка данных из 1С МиниДеньги в 1С:Деньги 8, редакция 2.0

Обмен между базами 1C Файловые протоколы обмена (TXT, XML, DBF), FTP v8 Домашние учет и финансы УУ Абонемент ($m)

Обработка для первоначальной загрузки данных (справочников и операций) в настольную программу 1С:Деньги 8, редакция 2.0 из файлы резервной копии мобильной программы 1С Миниденьги.

2 стартмани

01.10.2015    18103    15    Claus32    5    

Редактор чеков ККМ Розница 2.0 - 2.3

Обработка документов Кассовые операции Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд БУ НУ Абонемент ($m)

Обработка чеков ККМ списком (редактирование, удаление, ...). Переформирование ОРП, связь чеков с ОРП. Редактирование времени КС. Редактирование суммы и времени выемки.

1 стартмани

06.08.2015    64603    597    Dima_    83    

Загрузка из Excel в 1С:Розница

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Склад и ТМЦ v8 Розница Россия УУ Абонемент ($m)

Универсальная загрузка Excel файлов в 1С:Розница 2.0

1 стартмани

27.05.2015    16609    110    KarinaSV    7    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Обмен между базами 1C Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    233544    4506    ekaruk    192    

Автоматическая установка себестоимости номенклатуры для конфигурации Розница 2.0 (2.1) +Бонус, исправляем ошибки при настройке расписания запуска для внешних обработок в Рознице 2.0

Прайсы Обработка документов Розничная торговля Ценообразование, анализ цен v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Обработка для автоматического создания документов Установка себестоимости, в случае если себестоимость не установлена на момент продажи. Помогает упростить установку себестоимости номенклатуры, если у вас в базе ведется учет по нескольким магазинам. Тестировалась на релизе 2.0.8.12 и 2.1.7.14. Подойдет для тех систем, где себестоимость номенклатуры одинакова для всех магазинов.

1 стартмани

31.03.2014    30214    75    sanches    15    

Выемка денежных средств из КассыККМ. Розница 2.0

Кассовые операции ККМ v8 Розница УУ Абонемент ($m)

Уставшим от отсутствия ВыемкиДС после закрытия кассовой смены посвящается. Подключаемая обработка. Управляемый интерфейс.

1 стартмани

12.12.2012    81879    530    StepByStep    40