Исправленный отчет 4-ФСС за 2-й квартал 2022

Публикация № 1689146 04.07.22

Бухгалтерский учет - Регламентированный учет и отчетность

4-ФСС ЗУП ошибка Приказ ФСС от 14.03.2022 80

Исправление ошибки в отчете 4-ФСС за 2-й квартал 2022 в новом релизе ЗУП КОРП 2.5 1.3.175.1 (Приказ ФСС от 14.03.2022 № 80).

В новом релизе  ЗУП КОРП 2.5 1.3.175.1 в регламентированном отчете 4-ФСС в форме ФормаОтчета2022Кв2 обнаружена ошибка при попытке выгрузить отчет 4-ФСС за 2-й квартал 2022 г.

Здесь публикую способ исправления и исправленный файл внешнего отчета 4-ФСС (РегламентированныйОтчет4ФСС.erf).

В отчете присутствует сслыка на процедуру ОбщегоНазначенияЗК.СкопироватьРекурсивно, которую нужно заменить на РегламентированнаяОтчетность.СкопироватьРекурсивно.

Протестировано на ЗУП 2.5 КОРП 1.3.175.1.

Можно заменить в форме ФормаОтчета2022Кв2 процедуру ЗаполнитьСодержательнуюЧасть на  указанную ниже

 

 

 

Процедура ЗаполнитьСодержательнуюЧасть(ПараметрыВыгрузки, УзелРодитель)
    
    УзелTITLE = ПолучитьПодчиненныйЭлемент(УзелРодитель, "TITLE");
    ЗаполнитьДаннымиУзел(ПараметрыВыгрузки, УзелTITLE);
    
    // Выгрузка таблиц 1, 3, 4.
    //
    Узел_F4INFO = ПолучитьПодчиненныйЭлемент(УзелРодитель, "F4INFO");
    
    Таблица1 = РегламентированнаяОтчетность.СкопироватьРекурсивно(мДанныеОтчета.ПолеТабличногоДокументаТаблица1);
    Таблица1.Вставить("Льгота60Процентов", ПараметрыВыгрузки.Льгота60Процентов);
    Таблица1.Вставить("ЧастичноеФинансированиеИзБюдж", ПараметрыВыгрузки.ЧастичноеФинансированиеИзБюдж);
    
    ЗаполнитьДаннымиУзел(Таблица1, Узел_F4INFO);
    ЗаполнитьДаннымиУзел(мДанныеОтчета.ПолеТабличногоДокументаТаблица3, Узел_F4INFO);
    ЗаполнитьДаннымиУзел(мДанныеОтчета.ПолеТабличногоДокументаТаблица4, Узел_F4INFO);
    
    // Выгрузка таблицы 1.1 (многострочная).
    //
    УзелF4CALCШаблон = ПолучитьПодчиненныйЭлемент(УзелРодитель, "F4CALC");
    
    Таблица1_1 = РегламентированнаяОтчетность.СкопироватьРекурсивно(мДанныеОтчета.ПолеТабличногоДокументаТаблица1_1);
    // Основной ВЭД.
    ОсновнойВЭД_Данные = Новый Структура;
    Для НомГрафы = 2 По 24 Цикл
        НомГрафыСтр = Формат(НомГрафы, "ЧЦ=2;ЧВН=");
        ВиртуальноеИмяПоказателя = "П0001100001" + НомГрафыСтр + "_1";
        РеальноеИмяПоказателя = "П00011ОСВЭД" + НомГрафыСтр;
        ОсновнойВЭД_Данные.Вставить(ВиртуальноеИмяПоказателя, Таблица1_1[РеальноеИмяПоказателя]);
    КонецЦикла;
    УзелF4CALC = СкопироватьУзел(УзелРодитель, УзелF4CALCШаблон);
    ВыгрузитьСтрокуМногострочнойЧасти(ОсновнойВЭД_Данные, УзелF4CALC, 1);
    // СКЕ.
    НомСтр = 1;
    Пока РегламентированнаяОтчетность.СвойствоОпределено(
        Таблица1_1, "П000110000103_" + Формат(НомСтр, "ЧГ=")) Цикл
        Если ЗначениеЗаполнено(Таблица1_1["П000110000103_" + Формат(НомСтр, "ЧГ=")]) Тогда
            Таблица1_1.Вставить("П000110000106_" + Формат(НомСтр, "ЧГ="), 0);
            Таблица1_1.Вставить("П000110000107_" + Формат(НомСтр, "ЧГ="), 0);
            Таблица1_1.Вставить("П000110000108_" + Формат(НомСтр, "ЧГ="), 0);
            УзелF4CALC = СкопироватьУзел(УзелРодитель, УзелF4CALCШаблон);
            ВыгрузитьСтрокуМногострочнойЧасти(Таблица1_1, УзелF4CALC, НомСтр);
        КонецЕсли;
        НомСтр = НомСтр + 1;
    КонецЦикла;
    
    // Выгрузка таблицы 2 (многострочная).
    //
    УзелF4DOGOVШаблон = ПолучитьПодчиненныйЭлемент(УзелРодитель, "F4DOGOV");
    
    Таблица2 = мДанныеОтчета.ПолеТабличногоДокументаТаблица2;
    НомСтр = 1;
    Пока РегламентированнаяОтчетность.СвойствоОпределено(
        Таблица2, "П000020000102_" + Формат(НомСтр, "ЧГ=")) Цикл
        Если ЗначениеЗаполнено(Таблица2["П000020000102_" + Формат(НомСтр, "ЧГ=")]) Тогда
            УзелF4DOGOV = СкопироватьУзел(УзелРодитель, УзелF4DOGOVШаблон);
            ВыгрузитьСтрокуМногострочнойЧасти(Таблица2, УзелF4DOGOV, НомСтр);
        КонецЕсли;
        НомСтр = НомСтр + 1;
    КонецЦикла;
    
КонецПроцедуры

Обновление от 19-07-2022:

Добавил новую версию отчета с автозаполнением

 

Скачать файлы

Наименование Файл Версия Размер
Исправленный отчет 4-ФСС за 2-й квартал 2022:

.erf 4,34Mb
19
.erf 4,34Mb 19 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user932790 05.07.22 16:01 Сейчас в теме
А ошибку 1С, зарегистрировало?
2. Alex1Cnic 145 06.07.22 08:08 Сейчас в теме
(1) Пока не видел сообщений от 1С про ошибку. Ну это обычная "нормальная" ситуация для 1С....
3. IlyaReznikov 07.07.22 10:02 Сейчас в теме
4. Lik2707 08.07.22 07:31 Сейчас в теме
Спасибо за подсказку. Также столкнулись с ошибкой проверки/выгрузки отчета. Исправления от 1С пока нет, а пользователям нужно сдавать отчеты. Пока поправим по Вашему способу.
5. OksDallas 22 11.07.22 04:55 Сейчас в теме
6. Gal4onoK_89 11.07.22 06:56 Сейчас в теме
Добрый день! А автозаполнение в данном отчёте не предусмотрено?
7. Alex1Cnic 145 11.07.22 08:58 Сейчас в теме
8. Gal4onoK_89 11.07.22 10:38 Сейчас в теме
(7) Заполнение по данным ИБ не предусмотрено. Просьба сориентировать, возможно ранее сталкивались.
9. Alex1Cnic 145 11.07.22 11:10 Сейчас в теме
(8)
Заполнение по данным ИБ не предусмотрено

Какая у вас конфигурация? Отчет проверен и автозаполение работает
10. Alex1Cnic 145 11.07.22 11:23 Сейчас в теме
(9)
Заполнение по данным ИБ не предусмотрено

Обновитесь до релиза ЗУП КОРП 2.5 1.3.175.1
11. kazan74 11.07.22 12:18 Сейчас в теме
При выгрузке упорно пишет : "Ошибок в отчете 1. Выгрузка прервана". Что делать? Текст модуля формы уже 1С исправила. Но ошибка все равно.
12. kazan74 11.07.22 13:10 Сейчас в теме
(11) Вопрос снят. Почему-то не во всех базах внешний подключается корректно по предложенной 1С схеме. И при формировании отчета упорно открывается непонятно что без красной надписи внешний отчет. В итоге я открывал обработку через меню файл с предложением зарегистрировать его в отчетах. И все нормально начинало работать.
m_b; user1294839; +2 Ответить
13. user1294839 12.07.22 16:35 Сейчас в теме
(12)Спасибо, помогло, на БП корп 2.0 Только так получилось. Таким способом она заменила вшитый отчёт и стало выгружаться
14. smewinka 14.07.22 11:36 Сейчас в теме
Спасибо, очень помогло для ЗУП КОРП, редакция 2.5 (2.5.175.1)
15. vita55555 18.07.22 13:50 Сейчас в теме
Всем привет, в пятницу 15.07.2022 выложили исправленный отчет, в котором работает выгрузка,
вижу что добавили вкладку - Платежи, и она авто не заполняется. Смотрел на ЗУП КОРП 2.5.175.1
16. Adiga126 31 18.07.22 15:31 Сейчас в теме
17. nat-sya 19.07.22 08:58 Сейчас в теме
большое спасибо автору, решили проблему
18. ;bubyf 20.07.22 09:59 Сейчас в теме
19. i_mak 21.07.22 14:31 Сейчас в теме
20. user1293128 21.07.22 14:36 Сейчас в теме
Добрый день. Теперь такая же проблема, если выгружать корректирующий отчет.
21. Stell 53 26.07.22 08:52 Сейчас в теме
На https://releases.1c.ru/version_files?nick=HRMCorp&ver=2.5.175.1 выложили обновление внешнего отчета для корректирующей.
22. Adiga126 31 26.07.22 13:51 Сейчас в теме
(21) Не помогло. Отправился только после того, как закомментировал в модуле строки с 3493 по 3498
IlyaReznikov; +1 Ответить
Оставьте свое сообщение

См. также

SALE! 25%

Из Excel в 1С "одним нажатием": УПД, ТОРГ-12, отчеты комиссионеров (ОЗОН, Вайлдберриз), заказы, счета, прайсы, номенклатура Промо

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля v8 v8::УФ Платформа 1C v8.2 1cv8.cf БУ УУ Платные (руб)

Универсальная обработка для загрузки документов из Excel в 1С. Не требует указания параметров (номера колонок, номер первой строки таблицы и т.д.) и предварительной настройки. Просто выбираете файл Excel, документ 1С и нажимаете кнопку "Загрузить". Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. Вместе с номенклатурой может найти контрагента, номер и дату документа, штрих-коды, серии ГТД, страну и т.д. Распознает документы ЛЮБОЙ ФОРМЫ (УПД, ТОРГ-12, заказ, отчет комиссионера и т.д.). Не требует MS Office. Содержит модуль работы с электронной почтой. Для поиска таблиц используются методы эвристического поиска. Загружает только то, что нужно, т.е. пропускает повторы шапки таблицы, заголовки, промежуточные итоги, подписи и т.д. Работает во всех основных конфигурациях 1С8. При покупке лицензии вы получите 1 месяц бесплатной тех.поддержки.

9000 7650 руб.

09.11.2016    175189    648    839    

Загрузка данных из 1С МиниДеньги в 1С:Деньги 8, редакция 2.0

Обмен между базами 1C Файловые протоколы обмена (TXT, XML, DBF), FTP v8 Домашние учет и финансы УУ Абонемент ($m)

Обработка для первоначальной загрузки данных (справочников и операций) в настольную программу 1С:Деньги 8, редакция 2.0 из файлы резервной копии мобильной программы 1С Миниденьги.

2 стартмани

01.10.2015    18103    15    Claus32    5    

Редактор чеков ККМ Розница 2.0 - 2.3

Обработка документов Кассовые операции Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд БУ НУ Абонемент ($m)

Обработка чеков ККМ списком (редактирование, удаление, ...). Переформирование ОРП, связь чеков с ОРП. Редактирование времени КС. Редактирование суммы и времени выемки.

1 стартмани

06.08.2015    64603    597    Dima_    83    

Загрузка из Excel в 1С:Розница

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Склад и ТМЦ v8 Розница Россия УУ Абонемент ($m)

Универсальная загрузка Excel файлов в 1С:Розница 2.0

1 стартмани

27.05.2015    16609    110    KarinaSV    7    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Обмен между базами 1C Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    233543    4506    ekaruk    192    

Автоматическая установка себестоимости номенклатуры для конфигурации Розница 2.0 (2.1) +Бонус, исправляем ошибки при настройке расписания запуска для внешних обработок в Рознице 2.0

Прайсы Обработка документов Розничная торговля Ценообразование, анализ цен v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Обработка для автоматического создания документов Установка себестоимости, в случае если себестоимость не установлена на момент продажи. Помогает упростить установку себестоимости номенклатуры, если у вас в базе ведется учет по нескольким магазинам. Тестировалась на релизе 2.0.8.12 и 2.1.7.14. Подойдет для тех систем, где себестоимость номенклатуры одинакова для всех магазинов.

1 стартмани

31.03.2014    30214    75    sanches    15    

Выемка денежных средств из КассыККМ. Розница 2.0

Кассовые операции ККМ v8 Розница УУ Абонемент ($m)

Уставшим от отсутствия ВыемкиДС после закрытия кассовой смены посвящается. Подключаемая обработка. Управляемый интерфейс.

1 стартмани

12.12.2012    81878    530    StepByStep    40