Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (ERP 2.5, УТ 11.5, КА 2.5, Розница 2.3)

Публикация № 1650529 25.04.22

Пользовательские инструменты - Обработка справочников

Расширение для типовых конфигураций. Позволяет сделать невидимым помеченные на удаление номенклатуру и характеристику номенклатуры при выборе и подборе во всех документах, где нужно выбирать или подбирать Номенклатуру и Характеристику номенклатуры, например в документах: Заказ клиента, Заказ поставщику, Реализация товаров и услуг, Приобретение товаров и услуг и т.д.

Когда справочник наполняется помеченными на удаление объектами и долго не представляется возможным удалить помеченные на удаление элементы, они начинают мешать пользователям выбирать значение справочника. Чтобы пользователям они не мешали,  было решено сделать данное расширение. В этом расширении при выборе или подборе Номенклатуры или Характеристики номенклатуры не видны элементы помеченные на удаление.

Например, у номенклатуры - Кондиционер ELEKTA имеется четыре характеристики. Характеристика "Автоуправление" помечена на удаление. Помеченная на удаление характеристика видна в списке всех характеристик.

 

 

При использовании данного расширения в заказе клиента при выборе характеристики, помеченной на удаление "Автоуправление" становится не видно.

 

 

также не видно помеченной на удаление характеристики "Автоуправление" при подборе номенклатуры по кнопке "Заполнить"

 

 

Теперь пользователь при выборе или подборе номенклатуры или характеристики номенклатуры не сможет выбрать помеченный на удаление элемент.

 
Подключение расширения:

 

Работоспособность расширения тестировалось на следующих конфигурациях:

  • 1С:ERP Управление предприятием 2 (2.5.7.390)
  • 1С:ERP Управление предприятием 2 (2.5.8.175)
  • Комплексная автоматизация 2 (2.5.7.390)
  • Управление торговлей, редакция 11 (11.5.7.390)
  • 1С:ERP Управление строительной организацией 2 (2.5.6.291)

11-05-2022:

Добавил раширение для 1С-Розница 2.3

Работоспособность расширения тестировалось на следующих конфигурациях:

  • Розница, редакция 2.3 (2.3.10.43)
  • Розница, редакция 2.3 (2.3.11.33)

Скачать файлы

Наименование Файл Версия Размер
Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (ERP 2.5, УТ 11.5, КА 2.5):

.cfe 82,56Kb
19
.cfe 82,56Kb 19 Скачать
Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (Розница 2.3):

.cfe 44,39Kb
5
.cfe 44,39Kb 5 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user595534_koshkina 26.04.22 08:34 Сейчас в теме
Расширение супер, спасибо!
Это то, что было крайне необходимо!
aibasoft; skmMining; user1778480; SergAl; +4 Ответить
2. Dem0 12 26.04.22 09:42 Сейчас в теме
Задача нужная, несколько раз приходилось делать, под разные конфигурации.
Автор, напиши, как реализовано, рлс, условное оформление или еще как-то?
3. Vladimir_D 110 26.04.22 10:55 Сейчас в теме
(2)Раз в описании написано, что в подборе или выборе, то значит поправил текст запроса для подбора. А в выборе еще проще - в настройках поля настроить отбор, но тут уже тоже лучше добавить в запрос динамического списка дополнительное условие на пометку удаления. В целом, ничего сложного.
4. may1c 2 26.04.22 14:02 Сейчас в теме
Подскажите, а при вводе в в строке документа номенклатура и характеристика тоже не будет подбираться?
Student1C; +1 Ответить
5. SergAl 659 26.04.22 14:32 Сейчас в теме
(4) Добрый день! Вы имеете ввиду, что если знать наименование помеченной на удаление номенклатуры или характеристики и вводить в строке это наименование с клавиатуры, то возможно ли его выбрать?
10. may1c 2 28.04.22 08:46 Сейчас в теме
11. SergAl 659 28.04.22 08:56 Сейчас в теме
(10) если вводить с клавиатуры, зная при этом наименование, то расширение позволит это сделать.
18. PrinzOfMunchen 83 06.06.22 07:08 Сейчас в теме
(11) Впишитесь в обработку получения данных выбора
6. user595534_koshkina 26.04.22 16:08 Сейчас в теме
Возникла ошибка у бухгалтерии при создании документа "Списание на расходы", просьба посмотреть.
Прикрепленные файлы:
7. SergAl 659 26.04.22 16:53 Сейчас в теме
13. user595534_koshkina 28.04.22 12:27 Сейчас в теме
(7) Да, сейчас все работает, спасибо!
8. Sanario 22 28.04.22 03:18 Сейчас в теме
А как ведет себя расширение, если подбор не визуальный, а например через ввод по строке?
9. SergAl 659 28.04.22 08:08 Сейчас в теме
(8) Вы имеете ввиду, что если знать наименование помеченной на удаление номенклатуры или характеристики и вводить в строке это наименование с клавиатуры?
14. Student1C 43 02.05.22 19:57 Сейчас в теме
(8) Чуть выше уже ответили, что даст выбрать )
17. oldcopy 141 30.05.22 12:35 Сейчас в теме
(14) Для таких целей мы при установке пометки удаления сразу добавляем к наименованию префикс, которого точно нет и быть не может у нормальной позиции справочника, скажем, 000.

Получается вместо условных Хлеб Белый - 000Хлеб Белый. Подбором выбрать такое трудно и сразу визуально видно, что что-то пошло не так. Хотя народ у нас талантливый, их такие мелочи не смущают.
19. PrinzOfMunchen 83 06.06.22 07:15 Сейчас в теме
(17) Если формы управляемые, то всё намного проще.
Процедура ОбработкаПолученияДанныхВыбора(ДанныеВыбора, Параметры, СтандартнаяОбработка) Экспорт

	Если Не КонтролироватьВыборЭлементов() Тогда
		Возврат;
	КонецЕсли; 	
	
	Отбор = Новый Структура;
	Если НЕ Параметры.Свойство("Отбор") Тогда
		Параметры.Вставить("Отбор", Отбор);
	КонецЕсли; 
	
	Параметры.Отбор.Вставить("ПометкаУдаления", Ложь);
	
КонецПроцедуры

Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка) Экспорт
	
	Если Не КонтролироватьВыборЭлементов() Тогда
		Возврат;
	КонецЕсли; 	
	
	Если ВидФормы = "ФормаВыбора" Тогда
		
		Отбор = Новый Структура;
		Если НЕ Параметры.Свойство("Отбор") Тогда
			Параметры.Вставить("Отбор", Отбор);
		КонецЕсли; 
		
		Параметры.Отбор.Вставить("ПометкаУдаления", Ложь);
			
	КонецЕсли; 
	
КонецПроцедуры
Показать
20. oldcopy 141 06.06.22 13:47 Сейчас в теме
(19) Это слишком радикально, бывают и ошибочные пометки на удаление.
12. Sanario 22 28.04.22 09:21 Сейчас в теме
Ну да. Например характеристику пометили на удаление. У них то наименования не уникальные, подбор вводом и как себя поведет расширение?
15. neverx6 10.05.22 22:54 Сейчас в теме
Добрый, будет ли работать с розницей 2.3?
16. SergAl 659 11.05.22 09:28 Сейчас в теме
(15) Добрый день! Создал расширение для Розницы 2.3.
Оставьте свое сообщение

См. также

SALE! 25%

Из Excel в 1С "одним нажатием": УПД, ТОРГ-12, отчеты комиссионеров (ОЗОН, Вайлдберриз), заказы, счета, прайсы, номенклатура Промо

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля v8 v8::УФ Платформа 1C v8.2 1cv8.cf БУ УУ Платные (руб)

Универсальная обработка для загрузки документов из Excel в 1С. Не требует указания параметров (номера колонок, номер первой строки таблицы и т.д.) и предварительной настройки. Просто выбираете файл Excel, документ 1С и нажимаете кнопку "Загрузить". Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. Вместе с номенклатурой может найти контрагента, номер и дату документа, штрих-коды, серии ГТД, страну и т.д. Распознает документы ЛЮБОЙ ФОРМЫ (УПД, ТОРГ-12, заказ, отчет комиссионера и т.д.). Не требует MS Office. Содержит модуль работы с электронной почтой. Для поиска таблиц используются методы эвристического поиска. Загружает только то, что нужно, т.е. пропускает повторы шапки таблицы, заголовки, промежуточные итоги, подписи и т.д. Работает во всех основных конфигурациях 1С8. При покупке лицензии вы получите 1 месяц бесплатной тех.поддержки.

9000 7650 руб.

09.11.2016    175189    648    839    

Загрузка данных из 1С МиниДеньги в 1С:Деньги 8, редакция 2.0

Обмен между базами 1C Файловые протоколы обмена (TXT, XML, DBF), FTP v8 Домашние учет и финансы УУ Абонемент ($m)

Обработка для первоначальной загрузки данных (справочников и операций) в настольную программу 1С:Деньги 8, редакция 2.0 из файлы резервной копии мобильной программы 1С Миниденьги.

2 стартмани

01.10.2015    18103    15    Claus32    5    

Редактор чеков ККМ Розница 2.0 - 2.3

Обработка документов Кассовые операции Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд БУ НУ Абонемент ($m)

Обработка чеков ККМ списком (редактирование, удаление, ...). Переформирование ОРП, связь чеков с ОРП. Редактирование времени КС. Редактирование суммы и времени выемки.

1 стартмани

06.08.2015    64603    597    Dima_    83    

Загрузка из Excel в 1С:Розница

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Склад и ТМЦ v8 Розница Россия УУ Абонемент ($m)

Универсальная загрузка Excel файлов в 1С:Розница 2.0

1 стартмани

27.05.2015    16609    110    KarinaSV    7    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Обмен между базами 1C Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    233543    4506    ekaruk    192    

Автоматическая установка себестоимости номенклатуры для конфигурации Розница 2.0 (2.1) +Бонус, исправляем ошибки при настройке расписания запуска для внешних обработок в Рознице 2.0

Прайсы Обработка документов Розничная торговля Ценообразование, анализ цен v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Обработка для автоматического создания документов Установка себестоимости, в случае если себестоимость не установлена на момент продажи. Помогает упростить установку себестоимости номенклатуры, если у вас в базе ведется учет по нескольким магазинам. Тестировалась на релизе 2.0.8.12 и 2.1.7.14. Подойдет для тех систем, где себестоимость номенклатуры одинакова для всех магазинов.

1 стартмани

31.03.2014    30214    75    sanches    15    

Выемка денежных средств из КассыККМ. Розница 2.0

Кассовые операции ККМ v8 Розница УУ Абонемент ($m)

Уставшим от отсутствия ВыемкиДС после закрытия кассовой смены посвящается. Подключаемая обработка. Управляемый интерфейс.

1 стартмани

12.12.2012    81878    530    StepByStep    40